New Cruise Control Switch not working

Home  \  Domestic Cars  \  New Cruise Control Switch not working

just today I put a new Cruise control switch in my 94 chevy cavalier. Everything on the switch is working except the cruise control. I was wondering if may get some idea's on what I could check on. I'm not too familiar with cars but any help would be greatly appreciated. Thank you. Brad

posted by  kearneyfireman

check the vacuum hose's and here's a wiring diagram

posted by  osborste

You probably need a new servo, which has a big rubber boot on it, and a throttle cable hooked up to it, it'll have two vaccum hoses and an electrical connector hooked up to it. Get a used servo if possible, from an autowrecker, new one's go for quite a bit of money.

It could also be your switch, but I bet the servo.

You should get a mechanic to look at it if you aren't too mechanically inclined, you may be replacing one or the other when it wasn't neccessary.

posted by  88GrandPrixSE

Thank you for your help everyone, It ends up the wires were loose, Someone had messed around in it before I bought it and had a little bit of trouble and didnt put the wires back together very good. I wiggled the wires around and retaped them and it's working great now. I really like doing the work on cars myself, I learn alot that way and I love being ouside when it's nice. It anything goes seriously wrong with it I take it to the shop. Once again thank yous alot. Before I forget there's is once more question. The cavaliers were recalled because the dash lights kept failing. By any chance would there be a way to get the dash lights working again? and if not, would it be a good or bad idea to drill holes up under the spedometer and wire up some lights on my own coming up from the bottom through the plastic?

posted by  kearneyfireman

check the headlight switch then check the bulb's its posible that they are all burnt and never changed you will have to pull the instrument panel out so you will need a manual for this if you have noy taken it apart before i'll check my manual and see if i can post anything to help you

posted by  osborste

I pulled out the panel and took out all the lights and looked at every one of them and they're all good, they all work. I even bought a different pannel from junk yard but that dont work either. would it be possible the wiring to one or more of the prongs is burnt out and not working and is it even worth fixing or would I be smarter to just put a hole in the back of the pannel and install my own light on a toggle switch? Thank you for your help. Brad

posted by  kearneyfireman

if all other lights work(heater,radio,ashtray,PRND1L)and not inst panel then the wire to the I/P is broken. if none of these light work check the dimmer switch then headlight switch.my diagram shows the wire being a grey wire for 93 and up you could try running a new wire from dimmer to the I/P
also the diagram show headlight switch has two fuse's 15amp and a 5amp
the 5amp is for the I/P and other lights

posted by  osborste

Ok I'll check on those wires. I noticed there was electrical tape on a few wires in the car when i was taking it apart but the only wrong with the car now is the dash lights. Thank you for your help, I'll let you know how that goes when I get that done. thank you. Brad

posted by  kearneyfireman

Your Message