1996 Nissan Altima GXE

Home  \  Asian Imports  \  1996 Nissan Altima GXE

I have an intermittent stalling problem on my Altima. The only code it is showing is the knock sensor. The distributor has been replaced, the MAF sensor was replaced, the plugs and wires were replaced as well, the fuel pump was pressureed checked and at spec, the fuel filter is new! :banghead:

The car will sputter and act as if it does not have enough fuel flow and sometime when the car is put into reverse it will stall right away (it is an automatic) The trans was checked to determine if I had a torque converter problem but all is ok! I do not believe the knock sensor would cause this problem as I have been told by a number of sources that this sensor would not generate the problems I am having. I am not sure what to check next as I am runiing out of options and would appreciate some advice from this forum to help out! :thumbs: Thanks much!

posted by  ragoodson5

One more peice of information the O2 sensor on exhaust manifold was replaced as well.

posted by  ragoodson5

undefined
i had same problem you did everything you did i did and more problem was miss direction distibutor was replaced six months ago so i did not replace it sure enough bad distributor sent it back as defect and replaced coil problem solved car runs great

posted by  micky#7

:cussing: I HERE YOU. I JUST STARTED HAVING A PROBLEM TODAY. MY HUBBY CALLED AND TOLD ME THAT THE CAR STALLED WHEN HE WAS TAKING OFF FROM A STOP. DID YOU EVER FIGURE OUT WHAT THE PROBLEM WAS ON THE CAR? IT IS IN GREAT SHAPE AND WE ARE THE ONLY OWNERS SO WE KNOW ALL THE HISTORY AND THIS IS THE FIRST REAL PROBLEM WE HAVE EVER HAD.

posted by  shan1205

My son was having same problem. We had the knock sensor replace and
fuel filter. The vehicle runs alot better but we are still having a little
hesitant when we press on the accelerator (not much only after veh has
been driving for a while). I am taking to mech tomorrow i will post the
result once we figure out the problem.

posted by  shularey

i have a 1994 altima gxe which i just bought with 85000 miles on it. it hesitates when accelerating and i took it to the mechanic who put it on the computer diagnostic and it came out with code 34 meaning knock sensor problems. i had it replaced (233 bucks) and it ran smooth for a while but now it still hesitates. i can just ignore this and drive the car like this or will it lead to further damage. and has anyone managed to resolve this problem. thanks

posted by  buzugee

i have a 1996 Nissan Altima GXE its manufactured in 9/95 so the 02 Sensor is bank 1 where do i huke this thing up i cant find the other one to replace it anyone know?

posted by  surfsk8drum

Not only did you revive a 2 1/2 year old thread, but you did so with a question that makes no sense. Good job. :doh:

posted by  vwhobo

on a 96 nissan altima GXE were is the Knock sensor located at ?

posted by  surfsk8drum

Your Message