BMW won't start

Home  \  European Imports  \  BMW won't start

Hi my name is Leron,I'm a college student, and a first time poster.
I have a 1990 325i 4 door automatic BMW. My car sits about 4 inches from the ground, so when I hit the speed bump at the bank I cracked my oil pan. The oil spilled on to the concrete. So I drove the car a quater of a mile to Auto Zone. When I got there the engine was smoking. Of coure Auto Zone is not going to have an oil pan for a BMW. The car got towed to my house and in the middle of taking off oil pan, I accidently hit the stater and almost got shocked. After replacing the pan I tried to start my car but all Im getting is a ka ka ka ka ka sound. The battery is charged, I can tell because my head lights and radio are coming on. I'm thinking its my starter. If you'll have any more suggestions please let me know, because I'm a college student and I need to get my only car back on the road.

posted by  Leron

you probably shouldn't have driven it at all...

posted by  jedimario

Post this in the R&M section. :thumbs:

posted by  StiMan

Thus the reason id never lower my car and im really scared of a body kit lol. Good ol lip kit for me :thumbs:

posted by  GonnaDie4TheGov

.
.
I know exactly what you are talking about...I went through three pans on this car...the blue e30.
.
http://img.photobucket.com/albums/v38/BavarianWheels/BMW_Family_15k.jpg

It was not a good idea to drive the car one inch! You'll have to go and get it looked at...I can't guess what went wrong...no oil is serious business in any car.
.
.

posted by  BavarianWheels

Thats a pretty little 7 bav:thumbs:

As for the starting...umm bad times...You shouldn't have driven your car at all.

posted by  Zalight

It's nice...but I wish it was the iL :doh:
.
.

posted by  BavarianWheels

Did you happen to disconnect the battery earth lead from the engine block and not re-fit it

posted by  Walke40

Your Message