1992 Eagle Talon Problems. Help!!!!!

Home  \  Repairs & Maintenance  \  1992 Eagle Talon Problems. Help!!!!!

I RECENTLY PERCHASED A 1992 EAGLE TALON 4 CYLYNDER 16 V DOHC. ABOUT 3 MONTHS AGO. i HAVE STARTED HAVING PROBLEMS WITH THE OIL PRESSURE. IF I AM DRIVING AND I COME TO A STOP, FOR EXAMPLE A TRAFFIC LIGHT MY OIL GAUGE GOES DOWN TO ALMOST NOTHING AND THE CAR STARTS SPUTTERING AS IF IT WANT TO CUT OFF, I THROW IT IN NEUTRAL UNTIL THE LIGHT CHANGES AND ONCE I START DRIVING THE OIL PRESSURE GOES BACK UP TO NORMAL. BUT ONCE I STOP AGAIN THE SAME PROBLEM HAPPENS AGAIN. IT IS USUALLY OK WHILE I AM IN MOTION EXCEPT FOR IF I DRIVE A GOOD DISTANCE THEN THE GAUGE WILL GO DOWN AND IT WILL START SPUTTERING WHILE I AM DRIVING. WHEN THIS HAPPENS I IMMEDIATLY GO TO THE FIRST GAS STATION AND CHECK THE OIL, IT IS USUALLY BONE DRY AT THIS POINT SO I ADD OIL, BUT WHEN I GET HOME AND LET THE CAR SIT FOR A FEW HOURS I CHECK THE OIL AGAIN , AND IT SEEMS AS IF ALL THE OIL THAT I THOUGHT WAS GONE RETURNS AND THEN I HAVE TOO MUCH OIL IN THE CAR. SO I TOOK THE CAR TO THE AUTO SHOP AND THEY CHANGED MY VALVE COVER GASKETS, MY OIL RINGS, PC VALVE AND UNCLOGGED 2 LINES THAT THEY SAID WERE CLOGGED. BUT TO MY SURPRISE THE CAR SEEMS TO BE WORSE NOW THAN IT WAS BEFORE. BEFORE IT ONLY DID IT SOMETIMES NOW IT LOSES OIL PRESSURE EVERYTIME I STOP. THIS IS REALLY MAKING ME NERVOUS. CAN SOMEONE PLEASE GIVE ME A CLUE AS TO WHAT MIGHT BE WRONG WITH MY CAR. MY NAME IS JAI, I AM 26 AND I LIVE IN MICHIGAN. THANK YOU FO ANY HELP YOU MIGHT BE ABLE TO GIVE ME. :ohcrap:

posted by  JAI2232

hey,

I just bought a 1990 talon AWD turbo (16 psi)

My car is cutting in and out and only running on 2 cylinders. I have no clue what it could be. the check engine light comes on and it wont hall itself. If you have any sugestions, email me at joeyb85@gmail.com. mabey its the same problem as yours.


joey

posted by  joeyb1985

could someone please help me with this problem my car is cutting out,as soon as i apply fuel it cuts then back on, i was told it was overboosting,it does this 95% of the time, i have changed the spark plug wires,plugs, fuel pump,clean my injectors, intake, checked every possible wire i could see,had my intercooler checked for holes,still same problem. 92 talon turbo awd. ,

posted by  turboawd

Your Message