94GrandAm losing power

Home  \  Repairs & Maintenance  \  94GrandAm losing power

I was just wondering if anyone could help me .My GrandAm started jerking the other day when i was driving.When i first start it up it seemed fine for a while now its really bad.When I start i n 1st gear ok 2nd gets worse and if i make to fifth gear it feels like someones pulling me backwards due to lack of power.Now its using tons of gas. Help Please

posted by  jerryhasproblem

need more info size of engine,milage, last tune up,any service engine light?
i only know its a 94 and standard from your post

posted by  osborste

The car is a quad 4 it 130,000 miles or so has not been tuned up lately.

posted by  jerryhasproblem

no engine light and have checked codes

posted by  jerryhasproblem

you may have high resistance in the plugs/wires making the ignition system work harder and break down under load the spark will find an easier path to ground instead of jumping the plug gap and if the plug wire's are still numbered 1 for cyl no1 and so on to no 4 those are original wire's and are over due to be changed and for plugs normal plugs are recommended on most cars to be changed every 30000 mile's or 24 to 30 months and recheck the gap on new plugs before installing unless you use platinum then dont gap them
normal tuneups should be at least wire's,plugs,airfilter,fuel and pcv if equipt

posted by  osborste

at first i thought it might be something electronic but now im not sure because the exhaust sounds muffled ?

posted by  jerryhasproblem

this little bit of info is late but now it could be a converter plugging up caused by excess fuel in exhaust and closing(melting)the honeycomb design of the converter check the by having a back pressure test done on the converter

posted by  osborste

maybe a plugged catalytic converter (or cadillac converter where i work)?

posted by  carls47807

do a complete tune up first.those are hideous engines

posted by  the lobster

Your Message