00 Saturn SL- Code 341 but NO Cam Pos Sensor. Now What...?

Home  \  Repairs & Maintenance  \  00 Saturn SL- Code 341 but NO Cam Pos Sensor. Now What...?

Hi. My 2000 Saturn SL has 122,000 miles. Shortly after I bought it 3 weeks ago the "Service Engine Soon" light came on and has remained on.

I did an oil change, new Bosch plugs (the expensive ones) & wires thinking this would help but it didn't, not the light anyway.

After finding a Haynes manual and reading up a bit I purchased a code reader thinking it would be my crystal ball. It shows the mysterious 341 code & a pending 341 code; "Camshaft Position Sensor A - Bank 1 CKT Range/Perf".

My manual makes no reference to any Camshaft Sensor or I would've replaced it days ago.

The only thing I notice performance wise is when it's idling, it feels like it's missing here & there... that studder thing. I suspect it's effecting gas mileage/performance but not sure because it's been this way since the day after I bought it. Seems to run good though considering...

Can someone please clue me in on what to do now...? :banghead:

Thank you...

p.s. I know there is NO Camshaft Position Sensor on my engine, I've figured that much out. Now will someone who also knows that tell me why & how to fix what's causing the 341 code...? :banghead:

posted by  drummer1966

i did


your code 0341 has to do with your cam shaft sensor your computer use's the signal from the sensor as well as the crankshaft sensor to adjust fuel injection timing and engine timing you are likely getting this code because the cam sensor is failing and needs to be replaced use the manual if you fell comfortable and test the cam sensor or take it in to your favorite shop and let them test

with a little miss typing should have said failing crank sensor sorry they use/share the same cuircut/function

posted by  osborste

there is another saturn with a similar problem i think a 2002 model...... the 341 thing

posted by  the lobster

same guy

posted by  osborste

Did you ever find out what was causing your problem? I have the same.

posted by  Bagpiper

Your Message