1998 Ford Escort ZX2 - Air Conditioning PROBLEM!

Home  \  Repairs & Maintenance  \  1998 Ford Escort ZX2 - Air Conditioning PROBLEM!

Air conditioner blower blows luke warm air. I jumped the compressor straight off the battery, it worked, so the compressor is good. I tried jumping it from the "low-side" but got no results in the compressor turning on. Any answers?
Is there an airconditioning relay in this car? If so its hidden. THANKS GUYS

posted by  billab0n98

make sure ther is a full charge of R-134-A (freon), also the escorts has had a few problems with the 4 wire hi side switch in the past
ppauley/cobra freek

posted by  ppauley

OK. I'll check that out. But yes it does have a full charge. ANYONE ELSE?

posted by  billab0n98

Replaced the switch...still not working :( PLEASE HELP ME OUT!

posted by  billab0n98

how did u check if u have enough? the car has a minimum pressure required to activate the compressor clutch.

posted by  thongsai

can someone get me the information on the "minimum pressure" ?

I believe it has a 1lb and 1/2 in it. I checked using a pari of gauges...

posted by  billab0n98

the gauges won't tell you any info you need to know w/o the compressor running. conversely, if you're saying that either of the gauges said 1-1/2, you're low...

posted by  dodger65

1 and 1/2 sounds right.. so u have a/c gauges? most system requires 30 psi to start the clutch.. if u are really sure u have refrigerant and enough psi, u can try to bypass the low pressure switch. its on ur accumulator.
green/red and orange wire.

edit: hmm i have two different gauges here.. it only tells me pounds of pressure (psi) and refrigerant temp. make sure u are reading ur gauges correctly.. or the above will damage ur compressor.

posted by  thongsai

what i'm saying is that, unless billab0n98 emptied out the system and put 1-1/2 lb. in there, there's really no way to tell how much is in there w/ the compressor not running...

posted by  dodger65

OK, its charged. I think i may have to replace the relay module.....just gotta find it

posted by  billab0n98

Hello my Name Is Clifton I dont no if you ever got this problom fixed but I had same probloum with mine The Control models bad. It sites under air filter houses relays for the compress two ways to get this part one is for about $175 Or Junk Yard. Hope this helps if you havent aready got it fixed

posted by  cdkeck40

Your Message