Surging at idle....What's the Problem??

Home  \  Repairs & Maintenance  \  Surging at idle....What's the Problem??

I hate to sound really dumb, but I know almost nothing about cars. Please, please, please somebody help me.
A couple weeks ago I was at a stop light when my car, a 98 Ford ZX2, shook really hard. For a second I thought that I had stalled but my engine started up again and continued surging and shaking every time I was at idle. A couple people told me that it could be my fuel injector so I had my fuel filter changed and the fuel injector checked, but it's fine. Could it be a bad sensor? If so, what sensor(s)?
Also, I noticed that when I reach 70 mph up to 80 mph my engine gets really loud as if it's in the wrong gear and I don't feel it shift as it usually would. I have an automatic so I know I don't have it in the wrong gear, but after it gets to 80 it sounds fine....and it's only when i'm between 70mph and 80 mph.
I've had this car for 6 years and it's the first time I'm having problems. I'd really like to know what I'm dealing with before I decide to bring it into a shop because I'm afraid of being taken advantage of. I'd appreciate any bit of information that you could give me.

posted by  KaliPnaiMix

when you say surge, does it try to accelerate even though you're holding down the brake?

From what you said thus far the surging is probably your Throttle Position Sensor going bad. I could be wrong, but from what you said thats my guess. Happened to me and my Camaro.

posted by  Joelius

hmm....how can I explain? I'll be idling at a stop or even when I'm in park and my car will shake. It shakes and shudders like the engine is about to die then it surges and then sounds fine for a couple seconds and begins to shake again. If I put it in neutral while I'm at a stop (i'm not sure if that's bad or not, so please tell me if it is) it's not as bad.
By the way, thank you for responding =)

posted by  KaliPnaiMix

Could be anything fuel, air or vaccum related. I had a Taurus that did that it was the fuel pump. I also have a Windstar that did it several times. First time was a faulty fuel injector. Second time was a DPFE sensor. It could also be a sticking PCV valve.

posted by  tr918

I don't know if this has anything to do with my problem, but a couple months ago I had brought my car in to get the spark plugs replaced. When I got into my car and started it it sounded funny and was shaking a lot. Come to find out the guy had messed up a wire or didn't connect it right (I'm not quite sure). It drove fine after they found out what the problem was. I'm just curious if it was possible that maybe he did mess something up and my problem could be related to that. Yet, I don't see why my car just started acting up now. Maybe it has nothing to do with that, I'm just asking stupid questions. :doh:

posted by  KaliPnaiMix

tuff call, surging could be many things, misfire or vacuum leak, or torque converter locking up. maybe a broken motor mount. lots of options here, sorry i cant help without more info. has the check engine light ever come on?

posted by  BanffAutoSpa_ap

i did have a broken motor mount and had that replaced thinking it'll hopefully solve the problem...but nope... :banghead:
so far i've had the radiator replaced (it was leaking), new spark plugs, new fuel filter, fuel injector checked and had fuel injector cleaning solution put in, new battery, new timing belt (i think that's what it was called), um...all new wheel bearings...although that has nothing to do w/ it. i haven't seen the check engine light come on ever.
i was watching my RPM needle while I was idling and what it does is when it shudders or surges the needle drops so i guess it can't really be called surging...well i don't know. like i said, i don't know much about cars :doh:
is there anyway i can check any of the parts you suggested on my own (well not me actually, but my hubby) w/o having to bring it to the shop?
thank you for your help :thumbs:

posted by  KaliPnaiMix

when it shudders like that does the needle actually drop right off and not read anything while the car is still running?

posted by  BanffAutoSpa_ap

*sigh* somebody asked me if my engine light ever turned on and I had said no, but today my engine light turned on. :banghead:
in regards to my needle dropping, it doesn't actually drop off if you mean that it's dropping to 0. when I'm idling it stays below 1 but drops a little and then returns.

posted by  KaliPnaiMix

your idle speed might be off. have someone adjust it. it always works for me.

posted by  SCMancini83

ok...well i went to autozone the other day and got a free diagnostic test...well they plugged some little thing into my car that came up with a code. From what they said my cylinder 3 was misfiring and that my spark plugs or wires could be bad. Coincidently it was the same one that the guy from econolube messed up but supposedly fixed when he changed my spark plugs 2 months ago. I replaced all spark plugs (they looked all burnt out) and the wires and that solved the problem with the shuddering and the needle dropping while i'm idling, but my service engine light is still on and my idle is still a little rough. it doesn't seem like my engine is about to die each time i'm at idle and rather than the surging it's just a constant shaking now.
any ideas?

posted by  KaliPnaiMix

they didn't reset the check engine light or did it just pop back on?
maybe shoulda brought it back if it came on right after that

posted by  BanffAutoSpa_ap

Great! Thank you :thumbs:

posted by  KaliPnaiMix

Your Message