Alright I give up!!!!!!

Home  \  Repairs & Maintenance  \  Alright I give up!!!!!!

Okay, sometimes when i shut down my camaro (year: 83, V6 3.1L New spark plugs, wires dist.) their is a Knocking sound comeing from the engin compartment, When this happenes the Engine rotates slowly then quits, What could be the source of this? ive pushed on the car while the car is off and i can hear a knocking sound comeing from the Driver's side of the engine, i've checked most of the exast pipe, and nothing is loose, anybody got any other ideas (going to check my moter mounts also, allthough i dont think thats the problem)
:banghead: :banghead:

83camaro

posted by  83camaro

It does sound like the motor mount is bad, I suggest replacing both of the motor mounts and the trans mount at the same time to preserve the angles on your driveshaft and eliminate the extra wear on the hoses and such. :thumbs:

posted by  srober32

Thanks Ill reply back if the motermounts are still in good shape, :thumbs:

posted by  83camaro

Well the motor mounts are in good shape.. so im still at a loss on what it could be... Anybody else got anysuggestions? :doh:


83camaro

posted by  83camaro

Sorry for a third post.. but i forgot to mention that this only happens when i shutdown my engine and only once in a while... (i know i should have said this earlier but oops)

83camaro :banghead:

posted by  83camaro

Are we talking engine run on?

posted by  Wally

When i shut down, (doesnt do it all the time) the engine contuines to rotate (very slowly) after i turn the key to the off postion. (other times, it shuts right down) but when it rotates it makes the noise.

83camaro

posted by  83camaro

You might like to try a top end cleaner.

posted by  Wally

will do!

posted by  83camaro

Your Message