Car Forums  

Go Back   Car Forums > Technical Discussions > Repairs & Maintenance
FAQ Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 03-03-2007, 06:49 PM   #1
cutshabs104
CF Newbie
 
Join Date: Mar 2007
Posts: 2
"96 Isuzu Hombre clutch stuck?

I was driving yesterday and i was accelerating around a corner when right below me (sounded liek transfer case) this wierd buzzing thats slowed with rps started and i had to stop becasue it wouldnt go back into gear. Once i stopped i could shift to first and be on my way. I thought that the 4wd was tryign to engage or somthing becasue i'd shift into 4wd than back into 2 wd for the gears to engage again. Okay if was doig that on and off for about a mile the noise would start after i go about 45 then id have to stop and start up again i was on the second mile and all of the sudden it does that again i stop but i cant put it back into gear.

When i shift into gear i dont have to use the clutch while the engine is running, but the gears dont engage.

please help
cutshabs104 is offline   Reply With Quote
Old 03-06-2007, 09:35 PM   #2
PontiacFan27
CF Extraordinaire
 
PontiacFan27's Avatar
 
Join Date: Oct 2005
Location: Grove City, PA
Posts: 1,332
Does the clutch pedal move like it should? How does it feel?
__________________
PontiacFan27 is offline   Reply With Quote
Old 03-07-2007, 05:18 AM   #3
cutshabs104
CF Newbie
 
Join Date: Mar 2007
Posts: 2
yeah it works fine, actually i gota use the clutch when the engine is on or else it will grind, but it dosent move when i give it gas, i can feel the gears engaging. its wierd
cutshabs104 is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Forum Jump



All times are GMT +1. The time now is 09:43 PM.

Powered by vBulletin Version 3.5.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 2002 - 2011 Car Forums. All rights reserved.