Car Forums  

Go Back   Car Forums > Technical Discussions > Repairs & Maintenance
FAQ Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 06-15-2007, 01:47 PM   #1
caverman
CF Newbie
 
Join Date: Jun 2007
Location: Lawrenceville, GA
Posts: 5
1996 Jeep Grand Cherokee Laredo 4.0

Hello, can anyone help me please. Funds are getting low and my Jeep quit on me. I unfortunately assumed it was the fuel pump as I could not hear it running. I ordered one and had it replaced and this was not the problem. The fuel pump works as we jumped it off but no fuel is getting to the engine and the fuel guage does not read anything in the tank. I know there is at least 10 gallons of fuel in the tank. Some say it is the computer (ecm) but at $681.72 from the dealer, I dont want to risk that much money with out knowing the problem. Is there anything else that I need to check before replacing the computer. Any help would be greatly appreciated. Thanks in advance.
caverman is offline   Reply With Quote
Old 06-16-2007, 02:33 PM   #2
caverman
CF Newbie
 
Join Date: Jun 2007
Location: Lawrenceville, GA
Posts: 5
Sorry for the confusion

I meant that we hooked a hot wire to the fuel pump and could then get it to work. I fear that it is the ecm but am having a friend that is a mechanic over hopefully today to help figure it out. Thanks so much for your reply. I have wiring diagrams and such so we will be investigating the problem.
caverman is offline   Reply With Quote
Old 06-17-2007, 04:17 PM   #3
caverman
CF Newbie
 
Join Date: Jun 2007
Location: Lawrenceville, GA
Posts: 5
The Problem Solved

We managed to get the fuel pump running by jumping the relay with a paper clip. After knowing we had fuel we tried to start the engine and discovered no power going to it at all. I will be replacing the computer in the morning and this should solve my problem. Thanks for the advice. Funny thing is, when I first went to get in it and go, I thought someone stole my gas too, lol. This will also teach me to assume that the fuel pump was bad but I do have a new one so that should be one less problem to worry about. If anyone needs and old one that works, let me know. Take care.

Last edited by caverman : 06-19-2007 at 10:21 PM.
caverman is offline   Reply With Quote
Old 06-19-2007, 02:43 PM   #4
caverman
CF Newbie
 
Join Date: Jun 2007
Location: Lawrenceville, GA
Posts: 5
The problem NOT Solved

I have about had enough of this. The Jeep has no power, I have replaced the fuel pump, the computer and still no power. The mechanic friend I had came over and said it was a computer so now I dont know what to do. Does anyone have anymore advise that you can provide to me. When you turn the key on none of the guages move but the computer center does come on, just none of the guages work. I have noticed in the past the neutral safety switch may be going out as you sometimes have to put it into neutral to crank it. Can that swith cause it to not get power? Thanks in advance.
caverman is offline   Reply With Quote
Old 06-19-2007, 10:17 PM   #5
caverman
CF Newbie
 
Join Date: Jun 2007
Location: Lawrenceville, GA
Posts: 5
Thumbs up Problem Finally Solved

OK! Let this be a lesson to those like me that assume certain things are wrong with your vehicle when they may not be. My problem turned out to be the Crankshaft Position Senser. Not the computer or fuel pump. This was a costly lesson for me to learn and thanks to the help of a local mechanic, this may have cost me much more. The only consolation to me is that this jeep has almost 200K on it and I am sure the other items that I replaced would have soon been needed. Thank you for any help that you suggested and I will keep posting things as I learn more about them. The installation was moderately difficult but only took about 15-20 minutes. Thanks to autozones database on repairing your car, I was able to find it quickly.
caverman is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Forum Jump



All times are GMT +1. The time now is 02:00 PM.

Powered by vBulletin Version 3.5.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 2002 - 2011 Car Forums. All rights reserved.