Car Forums  

Go Back   Car Forums > Technical Discussions > Repairs & Maintenance
FAQ Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 12-01-2008, 10:05 PM   #1
jayla
CF Newbie
 
Join Date: Dec 2008
Posts: 4
Question Acceleration problems...

This just happened today as I was driving my car a 1991 cadillac deville on my way home, the car just suddenly slowed down. I pressed on the gas to give it more power but it's not accelerating the way it normally does. I put it on park and it's still not accelerating. The car sounds different now like it's choking sounds rough. I never had any major problems, this is the first. Does anyone know what the problem is? THANX! Jayla

Last edited by jayla : 12-01-2008 at 10:44 PM.
jayla is offline   Reply With Quote
Old 12-01-2008, 10:13 PM   #2
BavarianWheels
Supreme Demagogue
 
BavarianWheels's Avatar
 
Join Date: Sep 2003
Location: So. Cal.
Posts: 3,154
Quote:
Originally Posted by jayla
This just happened today as I was driving my car a 1991 cadillac deville on my way home, the car just suddenly slowed down. I pressed on the gas to give it more power but it's not accelerating the way it normally does. I put it on park and it's still not accelerating. I never had any major problems, this is the first. Does anyone know what the problem is? THANX! Jayla

Any other symptoms or noises, steam/smoke, smells...otherwise it just sounds like you just ran out of fuel.
.
.
__________________

Bav's Favorite Track Vehicle
Posts Deleted for Use of Profanity = 2
BavarianWheels is offline   Reply With Quote
Old 12-01-2008, 10:19 PM   #3
newyorker
MXman
 
newyorker's Avatar
 
Join Date: Nov 2005
Location: Philly
Posts: 5,291
Yea, it could be fuel, or a similar issue to what I had in my Pontiac which I suspect was the torque converter where the RPM would still rise and engine worked fine but there was a slipping type of effect going on between the engine and transmission.

Did the car start running rough or anything like that?
__________________
04 Mazdaspeed Miata #2373/4000: IHI, BBS, Harddog, Flyin'Miata.

newyorker is offline   Reply With Quote
Old 12-01-2008, 10:19 PM   #4
jayla
CF Newbie
 
Join Date: Dec 2008
Posts: 4
acceleration problems...

Quote:
Originally Posted by BavarianWheels
Any other symptoms or noises, steam/smoke, smells...otherwise it just sounds like you just ran out of fuel.
.
.


It smells a little and it sounds different like it's choking. I filled up the tank yesterday.
jayla is offline   Reply With Quote
Old 12-01-2008, 10:28 PM   #5
jayla
CF Newbie
 
Join Date: Dec 2008
Posts: 4
Quote:
Originally Posted by newyorker
Yea, it could be fuel, or a similar issue to what I had in my Pontiac which I suspect was the torque converter where the RPM would still rise and engine worked fine but there was a slipping type of effect going on between the engine and transmission.

Did the car start running rough or anything like that?

yes it runs rough and sounds rough like it's choking.

Last edited by jayla : 12-01-2008 at 10:47 PM.
jayla is offline   Reply With Quote
Old 12-01-2008, 11:38 PM   #6
newyorker
MXman
 
newyorker's Avatar
 
Join Date: Nov 2005
Location: Philly
Posts: 5,291
Quote:
Originally Posted by jayla
yes it runs rough and sounds rough like it's choking.
Could be a misfiring issue then...in other words, spark plugs, wires, distributor/cap...or it could be something completely different.

What does it smell like?
__________________
04 Mazdaspeed Miata #2373/4000: IHI, BBS, Harddog, Flyin'Miata.

newyorker is offline   Reply With Quote
Old 12-02-2008, 02:46 AM   #7
jayla
CF Newbie
 
Join Date: Dec 2008
Posts: 4
Quote:
Originally Posted by newyorker
Could be a misfiring issue then...in other words, spark plugs, wires, distributor/cap...or it could be something completely different.

What does it smell like?


Smells like burnt rubber smell.

Last edited by jayla : 12-02-2008 at 02:48 AM.
jayla is offline   Reply With Quote
Old 12-07-2008, 10:23 PM   #8
jedmann1989
CF Newbie
 
jedmann1989's Avatar
 
Join Date: Dec 2008
Posts: 9
Quote:
Originally Posted by newyorker
Could be a misfiring issue then...in other words, spark plugs, wires, distributor/cap...or it could be something completely different.

What does it smell like?
I agree. Check the fuel filter, spark plugs, wires, air filter. All the basic stuff.
__________________
My Cars:

2009 Ford Mustang GT TT
1993 Mazda Rx7 Twin Turbo LS7
1991 Mistubishi 3000gt VR4

Coming Soon:

Custom body C5 Vette
jedmann1989 is offline   Reply With Quote
Old 12-07-2008, 11:22 PM   #9
Satty101
CF's L body Freak
 
Satty101's Avatar
 
Join Date: Sep 2003
Location: Colorado Springs CO
Posts: 2,865
I'd change the fuel filter aswell. Maybe 15 bucks, and usually easy to replace. This alone will cause your studering issue, but not the smell. Also, if you change the FF, make sure you cycle the key on and off a few times to get fuel pressure back so you don't start it dry (Thats bad...).
__________________
My cars:

1999 Chevrolet Camaro SS (PC'd)
1994 Chevrolet Beretta Z26 Q4 (W41 M90'd)
2004 Chevrolet Silverado 2500 (4WD)

My wife's cars:

1971 Dodge Charger SE (stock and original 383 auto)
2004 Subaru Impreza WRX (kid-hauler)
Satty101 is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Forum Jump



All times are GMT +1. The time now is 04:47 PM.

Powered by vBulletin Version 3.5.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 2002 - 2011 Car Forums. All rights reserved.