Car Forums  

Go Back   Car Forums > Technical Discussions > Repairs & Maintenance
FAQ Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 09-29-2008, 07:43 PM   #1
deadbolt
CF Newbie
 
Join Date: Sep 2008
Posts: 1
Exclamation Renult Clio 95 - temp guage at 3/4

Hi guys,
I'm new here
I usually drive my Clio locally but started working at a new job 25 miles from home. First day of work, I got on the highway and the temp gauge started climbing, as my speed went up so did the temp. When I stopped at a light the temp came slowly back down again. by the time I arrived at work the gauge was 3/4 I took a look under the hood (car running) and saw the fan working. So I took the car in for a repair and I was told that I needed to replace the Thermostat, water pump, and have the radiator cleaned and replace the coolant liquid, Done all that yet the temp gauge still hits the 3/4 mark. so I went back to the garage and they told me that they checked with Renault and the car is suppose to do that!?!? I was stunned... is this true? have they "screwed" me?

Thanks for your help!!

Last edited by deadbolt : 09-29-2008 at 07:48 PM.
deadbolt is offline   Reply With Quote
Old 09-30-2008, 03:41 PM   #2
trainingwheels
CF Newbie
 
Join Date: Sep 2008
Posts: 4
I'm not exactly sure about this but maybe the temperature indicator or gauge has the problem. Maybe it is not working properly anymore and needs to be replaced
trainingwheels is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Forum Jump



All times are GMT +1. The time now is 09:07 PM.

Powered by vBulletin Version 3.5.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 2002 - 2011 Car Forums. All rights reserved.