Car Forums  

Go Back   Car Forums > Technical Discussions > Repairs & Maintenance
FAQ Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 08-21-2005, 04:02 PM   #1
K3NN3Th
CF Newbie
 
Join Date: Aug 2005
Location: Arkansas
Posts: 1
95 Saturn SL2 @ 35mph

A few days ago I was driving home from work. The speed is 30mph most of the way. I didn't notice anything wrong at that speed. On the last road the speed gets to 35mph. As I accelerated to 35 the car started to jerk just a little but the rpm stayed where it should be. When I got to 35mph the rpm fell to about 300 and just sputtered. Luckily I was right at my apartment. I parked and turned off the car, turned it back on and it was still sputtering but only for about 20 seconds. Then the rpm went back to normal and it idled fine. This happens every trip at about the same speed. Also when it acts up like this there is a funny smell coming from the exhaust. Not sure what it smells like. Any ideas?
K3NN3Th is offline   Reply With Quote
Old 08-21-2005, 04:35 PM   #2
Macc
CF Enthusiast
 
Join Date: Jul 2005
Posts: 101
Is the smell from the exhaust kinda like rotten eggs (or potentially gas)? Do own or have access to a voltmeter?
Macc is offline   Reply With Quote
Old 08-27-2005, 06:42 AM   #3
DeEmo25
CF Newbie
 
Join Date: Aug 2005
Posts: 2
this happens to me sometime but no funny smell its only when i stay between 30s for a constant time...its a saturn thing
DeEmo25 is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Forum Jump



All times are GMT +1. The time now is 06:11 PM.

Powered by vBulletin Version 3.5.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 2002 - 2011 Car Forums. All rights reserved.