Car Forums  

Go Back   Car Forums > Technical Discussions > Repairs & Maintenance
FAQ Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 05-04-2005, 12:44 AM   #1
bmxmom
CF Newbie
 
Join Date: May 2005
Posts: 3
1989 Chevy Cavalier

Hi all, need some help plzzzzzz...... I have a 1989 chevy cavalier. The check engine light comes on sometimes, have had it checked for codes and no codes were found, i replaced the map sensor and had my old one checked and was told it was good so i put it back on my car. What my car does is, when the check engine light is on, it will bog down like it isn't getting any gas and then when i put in the clutch to either come to a stop or slow down it dies, but will restart again. I have replaced the throttle body about 2 years ago. Friend of mine put on a new fuel fliter telling me it was that, but it stills does that, checked with another person and they gave me this site, someone plz help me......Thanks
bmxmom is offline   Reply With Quote
Old 05-04-2005, 12:54 AM   #2
osborste
the canuck tech
 
osborste's Avatar
 
Join Date: Mar 2005
Location: ontario canada
Posts: 875
Quote:
Originally Posted by bmxmom
Hi all, need some help plzzzzzz...... I have a 1989 chevy cavalier. The check engine light comes on sometimes, have had it checked for codes and no codes were found, i replaced the map sensor and had my old one checked and was told it was good so i put it back on my car. What my car does is, when the check engine light is on, it will bog down like it isn't getting any gas and then when i put in the clutch to either come to a stop or slow down it dies, but will restart again. I have replaced the throttle body about 2 years ago. Friend of mine put on a new fuel fliter telling me it was that, but it stills does that, checked with another person and they gave me this site, someone plz help me......Thanks

4 or 6 cylinder
check engine(red light) not service engine soon(amber/yellow light)
have the oil pressure tested i belive your engine has very low oil psi causeing the fuel pump to shut down the oil pressure switch take over from the fuel pump relay once the engine is running if the oil pressure switch see's low pressure or no pressure the fuel pump is shut down to save the engine from further damage
__________________

without seeing or hearing your problem all i can do is offer advice on what to check
my new toy

<Link removed>......Please read the rules on advertising!

Last edited by osborste : 05-04-2005 at 01:26 AM.
osborste is offline   Reply With Quote
Old 05-04-2005, 04:25 AM   #3
bmxmom
CF Newbie
 
Join Date: May 2005
Posts: 3
1989 Chevy Cavalier

It is a 4 cyliinder, and the service engine light is yellow (sorry forgot to put that information in there). Thanks again
bmxmom is offline   Reply With Quote
Old 05-04-2005, 04:42 AM   #4
osborste
the canuck tech
 
osborste's Avatar
 
Join Date: Mar 2005
Location: ontario canada
Posts: 875
Quote:
Originally Posted by bmxmom
It is a 4 cyliinder, and the service engine light is yellow (sorry forgot to put that information in there). Thanks again

that changes alot the service engine light may come on with a bad crankshaft sensor engine would stumble /stall if signal was lost
or could also be a bad ignition coil(you have 2) or ignition module
i've included attachment so you can see the parts that i refered to
__________________

without seeing or hearing your problem all i can do is offer advice on what to check
my new toy

<Link removed>......Please read the rules on advertising!
osborste is offline   Reply With Quote
Old 05-04-2005, 06:41 AM   #5
srober32
CF Addict
 
srober32's Avatar
 
Join Date: Feb 2005
Location: Detroit, Michigan
Posts: 442
Have you tried getting the codes read when the car is acting up? Autozone and other auto parts stores do this testing for free.
__________________
When replacing your altenator, make sure your battery is fully charged.
srober32 is offline   Reply With Quote
Old 05-04-2005, 08:34 AM   #6
bmxmom
CF Newbie
 
Join Date: May 2005
Posts: 3
1989 Chevy Cavalier

Yes Srober32 I have had the codes checked, once from Auto Zone and from a mechanic. Everytime it shows no codes. That is why the first person told me it was the fuel filter, and he put a new one on and withing 2 hrs after that the light came back on and was doing it again. Tonight, the car acted like the battery was low and after I got it started and was going down the road it was acting like it wasn't getting any power (the service engine light was not on), seemed weird, I reved up the motor and then it seemed to be fine, parked it in garage, will try to start it up again in the morning....Thanks you all are a big help to me..
bmxmom is offline   Reply With Quote
Old 05-04-2005, 01:53 PM   #7
osborste
the canuck tech
 
osborste's Avatar
 
Join Date: Mar 2005
Location: ontario canada
Posts: 875
Quote:
Originally Posted by bmxmom
Yes Srober32 I have had the codes checked, once from Auto Zone and from a mechanic. Everytime it shows no codes. That is why the first person told me it was the fuel filter, and he put a new one on and withing 2 hrs after that the light came back on and was doing it again. Tonight, the car acted like the battery was low and after I got it started and was going down the road it was acting like it wasn't getting any power (the service engine light was not on), seemed weird, I reved up the motor and then it seemed to be fine, parked it in garage, will try to start it up again in the morning....Thanks you all are a big help to me..

you had the car's codes read twice with no code's stored i have seen this in the past its posiable the ecm(computer)is failing or wireing to the computer is damaged/loose connections
you could have it checked have them tap on the ecm (bumpy roads/vibration)if the car act's up they can similate the problem
__________________

without seeing or hearing your problem all i can do is offer advice on what to check
my new toy

<Link removed>......Please read the rules on advertising!
osborste is offline   Reply With Quote
Old 05-05-2005, 01:01 AM   #8
BanffAutoSpa_ap
Pants The Ripper
 
BanffAutoSpa_ap's Avatar
 
Join Date: Jan 2005
Location: Southern Alberta Likes:Long walks on the beach.....after anal
Posts: 1,510
if you think the car acted like the battery was low....you know the car best so your probably on the right track, with an alternator that is crapping out at idle or anytime then you will be tracing problems till the cows come home, keep it simple and check the integrity of your charging system first
__________________
Despite the high cost of living, it remains very popular.
BanffAutoSpa_ap is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Forum Jump



All times are GMT +1. The time now is 05:07 AM.

Powered by vBulletin Version 3.5.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 2002 - 2011 Car Forums. All rights reserved.