Car Forums  

Go Back   Car Forums > Technical Discussions > Repairs & Maintenance
FAQ Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 06-17-2005, 05:58 PM   #1
mohawk
CF Newbie
 
Join Date: Jun 2005
Posts: 2
Wrangler engine surges at startup

Hi, just ripped off my exhaust manifold and replaced it. Now on startup the engine surges like I've got my foot on the gas and I have to shut it off after about one or two seconds to keep the engine from blowing! Checked the throttle linkage, the intake valve isn't even opening. Any ideas?
mohawk is offline   Reply With Quote
Old 06-17-2005, 11:42 PM   #2
srober32
CF Addict
 
srober32's Avatar
 
Join Date: Feb 2005
Location: Detroit, Michigan
Posts: 442
Sound like a vucume leak.
__________________
When replacing your altenator, make sure your battery is fully charged.
srober32 is offline   Reply With Quote
Old 06-18-2005, 12:20 AM   #3
mohawk
CF Newbie
 
Join Date: Jun 2005
Posts: 2
Yep

Leak at the gasket. I'd bought a piece of junk gasket from Advance that didn't even match up completely right (think it must've been a universal fit) so I had to trim it. They charged me 16.99 ~ got an OEM one from the dealership for 14.10, stuck it on & I'm in business!
mohawk is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Forum Jump



All times are GMT +1. The time now is 08:55 AM.

Powered by vBulletin Version 3.5.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 2002 - 2011 Car Forums. All rights reserved.