Car Forums  

Go Back   Car Forums > Vehicle Specific > Classic Cars
FAQ Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 07-30-2005, 01:35 AM   #1
mustang90
CF Newbie
 
Join Date: Jul 2005
Posts: 3
power steering squeal

Tried the ps fluid then went to ps stop leak. Did not work and sound getting worse. When taking it into a mechanic, what might be some of the causes I could hear from them? Being female one needs to be a bit knowledgeable. Any info would be greatly appreciated. The ole' girl has 251,000 K and still running strong. Not burning one drop of oil. Have been told that no problem with these cars of getting 300,000 K. I love my mustang
mustang90 is offline   Reply With Quote
Old 07-30-2005, 02:43 AM   #2
corbett_auto
CF Addict
 
corbett_auto's Avatar
 
Join Date: Oct 2004
Location: just west of Charlotte, NC
Posts: 448
Some of the things I'd look at first would be:
  1. loose belt
  2. worn belt
  3. pulley out of alignment

None of the above problems should cost too much, worst case is a bad pump and they aren't too expensive.

Let us know what they tell you and what they will charge, someone here will let you know if it sounds reasonable.
corbett_auto is offline   Reply With Quote
Old 07-30-2005, 03:19 AM   #3
mustang90
CF Newbie
 
Join Date: Jul 2005
Posts: 3
Thanks for the quick info. Going to get the engine shampooed then take the car in. Will get back to you with causes and prices.
mustang90 is offline   Reply With Quote
Old 07-30-2005, 04:05 PM   #4
dodger65
I know more than Wally...
 
dodger65's Avatar
 
Join Date: Apr 2005
Location: U.S. - Midwest
Posts: 2,117
Quote:
Originally Posted by mustang90
Thanks for the quick info. Going to get the engine shampooed then take the car in. Will get back to you with causes and prices.

don't forget the conditioner...
__________________
"Everyone is someone else's weirdo"

dodger65 is offline   Reply With Quote
Old 08-10-2005, 01:36 AM   #5
mustang90
CF Newbie
 
Join Date: Jul 2005
Posts: 3
Smile conditioner

Too bad I got your advice to late. Now know why the ole' girl didn't look so glamorous, lacked that sheen and not much bounce
I have a new Reman rack plus had to go for a PS hose. This was the original setup and the hose was totally rotted. Not bad for being 16 yrs. Lots a good yrs left, just a rust cloud following, typical Ford.
mustang90 is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Forum Jump



All times are GMT +1. The time now is 04:54 AM.

Powered by vBulletin Version 3.5.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 2002 - 2011 Car Forums. All rights reserved.