Car Forums  

Go Back   Car Forums > Vehicle Specific > European Imports
FAQ Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 09-08-2005, 06:41 PM   #1
Leron
CF Newbie
 
Join Date: Sep 2005
Posts: 1
BMW won't start

Hi my name is Leron,I'm a college student, and a first time poster.
I have a 1990 325i 4 door automatic BMW. My car sits about 4 inches from the ground, so when I hit the speed bump at the bank I cracked my oil pan. The oil spilled on to the concrete. So I drove the car a quater of a mile to Auto Zone. When I got there the engine was smoking. Of coure Auto Zone is not going to have an oil pan for a BMW. The car got towed to my house and in the middle of taking off oil pan, I accidently hit the stater and almost got shocked. After replacing the pan I tried to start my car but all Im getting is a ka ka ka ka ka sound. The battery is charged, I can tell because my head lights and radio are coming on. I'm thinking its my starter. If you'll have any more suggestions please let me know, because I'm a college student and I need to get my only car back on the road.
Leron is offline   Reply With Quote
Old 09-08-2005, 09:42 PM   #2
jedimario
Mr. Hot Wheels
 
jedimario's Avatar
 
Join Date: Jul 2005
Location: Clemson University
Posts: 2,149
you probably shouldn't have driven it at all...
__________________


UNBAN WHAT
BAN BAV
jedimario is offline   Reply With Quote
Old 09-09-2005, 12:05 AM   #3
StiMan
CF Retired Post Whore
 
StiMan's Avatar
 
Join Date: Mar 2004
Location: Dallas, TX, USA
Posts: 2,964
Post this in the R&M section.
__________________
John

StiMan is offline   Reply With Quote
Old 09-09-2005, 01:52 PM   #4
GonnaDie4TheGov
CF's Only Jersey Boy
 
GonnaDie4TheGov's Avatar
 
Join Date: Apr 2005
Location: Mays Landing, NJ
Posts: 619
Thus the reason id never lower my car and im really scared of a body kit lol. Good ol lip kit for me
__________________

2001 Honda K-1 Accord Attack
GonnaDie4TheGov is offline   Reply With Quote
Old 09-09-2005, 02:53 PM   #5
BavarianWheels
Supreme Demagogue
 
BavarianWheels's Avatar
 
Join Date: Sep 2003
Location: So. Cal.
Posts: 3,154
.
.
I know exactly what you are talking about...I went through three pans on this car...the blue e30.
.


It was not a good idea to drive the car one inch! You'll have to go and get it looked at...I can't guess what went wrong...no oil is serious business in any car.
.
.
__________________

Bav's Favorite Track Vehicle
Posts Deleted for Use of Profanity = 2
BavarianWheels is offline   Reply With Quote
Old 09-09-2005, 09:12 PM   #6
Zalight
Who's house? Runs house.
 
Zalight's Avatar
 
Join Date: Mar 2004
Location: Albuquerque, New Mexico
Posts: 2,264
Thats a pretty little 7 bav

As for the starting...umm bad times...You shouldn't have driven your car at all.
__________________
1999 BMW ///M3
Zalight is offline   Reply With Quote
Old 09-10-2005, 12:45 AM   #7
BavarianWheels
Supreme Demagogue
 
BavarianWheels's Avatar
 
Join Date: Sep 2003
Location: So. Cal.
Posts: 3,154
Quote:
Originally Posted by Zalight
Thats a pretty little 7 bav

As for the starting...umm bad times...You shouldn't have driven your car at all.

It's nice...but I wish it was the iL
.
.
__________________

Bav's Favorite Track Vehicle
Posts Deleted for Use of Profanity = 2
BavarianWheels is offline   Reply With Quote
Old 10-03-2005, 06:38 PM   #8
Walke40
CF Newbie
 
Join Date: May 2005
Posts: 3
Question

Did you happen to disconnect the battery earth lead from the engine block and not re-fit it
Walke40 is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Forum Jump



All times are GMT +1. The time now is 03:16 AM.

Powered by vBulletin Version 3.5.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 2002 - 2011 Car Forums. All rights reserved.