Car Forums  

Go Back   Car Forums > Technical Discussions > Repairs & Maintenance
FAQ Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 11-02-2005, 03:12 PM   #1
fourriversbear
CF Newbie
 
Join Date: Nov 2005
Posts: 19
Big problems with Emissions/ECM 89 Firebird

The vehicle is a 89 Firebird Formula Engine is a Small block 350 TPI. The vehicle failed MD emissions, but has no check engine lights on. It passed the CO2 and pgm was very low, it failed the NO2 and was reading 3.5 pgm State Standard is 2.1. Also the primary cooling fan will not come on. It does work I have now jumped the fan and the relay. I went to Advance Auto Parts last night to run a diagnostic. The hand held scanner would not communicate with the ECM in drive mode. It did communicate with the ECM in field service mode and could read the PROM and stream data, also check air senor which indicated was working fine. It also showed the fan request on, but no fan working. It seems the ECM is not controlling the engine functions. I went home and tested the diag port by jumping the A and B turned the ignition key and gave me an error 12 code. One flash followed by two short. However when shorting the A and B the secondary fan came on in the engine which is not controlled by the ECM. What is going on??? Any advise on tracking the problem would be greatly appreciated. In addition the motor is running hot, because when I pulled the plugs they were white tipped. Sounds like the fuel mixture is to high and the ECM is not correcting problem.
fourriversbear is offline   Reply With Quote
Old 11-03-2005, 01:04 AM   #2
dodger65
I know more than Wally...
 
dodger65's Avatar
 
Join Date: Apr 2005
Location: U.S. - Midwest
Posts: 2,117
does the car run fine otherwise? how hot is hot? the fans in those cars usually don't kick on until the temp (on the gauge) reads in the neighborhood of 220... as far as the emissions, i would take it to an exhaust shop and have them do a temp test on the catalytic converter w/ a pyrometer. chances are, it's probably empty or not functioning... there should be a temp rise of better than 100 degrees between the inlet of the converter and the outlet of the converter. the fan (at least in MY firebird) always comes on when shorting out the aldl... how did you jump the relay exactly?
__________________
"Everyone is someone else's weirdo"

dodger65 is offline   Reply With Quote
Old 11-03-2005, 02:11 PM   #3
fourriversbear
CF Newbie
 
Join Date: Nov 2005
Posts: 19
The Firebird appears to run fine, gets very poor gas mileage and the exhaust has a abnormal gas fume smell. (that could have something to do with the Vapor canister or a cracked hose, I will have to check). I know the car runs hot because the spark plug tips are white. (at least in the cylinder). If running on the highway the car stays at about 180 degrees. If in traffic it can get up to 240 degrees. Jumping the primary fan I closed the circuit and applied 12 volts from the battery (on wiring harness) Pulled off the relay, but placed a good relay on the harness when I had the scanner hooked up. The scanner was showing a "fan request" on at 200 degrees. Scanner was in "field service mode" The secondary fan is turning on at 230 degress, exactly when it is suppose too. It is good to know the secondary fan comes on when you jump the aldl. (thought I may have had a wiring nightmare) Converters are good, I just replaced one, and the other was tested. CO2 is very low and No2 off the chart. I am trying to determine if the EGR valve is bad with out taking off the plenum. I still can't figure out why the primary fan never comes on. The motor is idling rough at 7.5 rpms (more like a bad vibration and purs when you reach 1K rpms).
fourriversbear is offline   Reply With Quote
Old 11-03-2005, 11:35 PM   #4
dodger65
I know more than Wally...
 
dodger65's Avatar
 
Join Date: Apr 2005
Location: U.S. - Midwest
Posts: 2,117
how many miles does it have on it? 750-800 rpm is a pretty normal idle... you might want to put a vacuum gauge on it and check your fuel pressure as well...
__________________
"Everyone is someone else's weirdo"

dodger65 is offline   Reply With Quote
Old 11-09-2005, 04:39 PM   #5
fourriversbear
CF Newbie
 
Join Date: Nov 2005
Posts: 19
Cats are bad

Thanks for all the input. I had a bad body ground from the battery, that little 12 guage wire!!!. The EGR sylenoid was bad and replaced. I am not getting enough back pressure from the cats and EGR valve will not work properly. The Converters appear to be empty and failed the thermo test.

ALSO, for all those 89-92 Firebird owners or Trans Am w/5.7 TPI. I talked to an emissions mechanic at a dealer and he told me that bird would have problems passing emission off the assembly line and has been a big issue with Pontiac for a long time.

Last edited by fourriversbear : 11-09-2005 at 04:41 PM.
fourriversbear is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Forum Jump



All times are GMT +1. The time now is 11:15 AM.

Powered by vBulletin Version 3.5.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 2002 - 2011 Car Forums. All rights reserved.