Car Forums  

Go Back   Car Forums > Technical Discussions > Repairs & Maintenance
FAQ Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 03-06-2006, 10:44 PM   #1
dan401964
CF Newbie
 
Join Date: Mar 2006
Posts: 1
98 jeep cherokee 4.0l

I replaced the thermostat and lower radiator hose but it is now leaking from behind the lower hose and is overheating and I have no heat any suggestions?
Also when i first start it and I drive it it will die and I have to wait a couple of minutes before it turns over and then I have to put foot to the floor to get it to start!
Thank You
Dan
dan401964 is offline   Reply With Quote
Old 03-07-2006, 01:58 AM   #2
97Talonchik
discombobulated
 
97Talonchik's Avatar
 
Join Date: Jun 2005
Location: Chattanooga, TN
Posts: 1,257
Did you close the drain cock? Did you put the hose clamps back on? Did you use a new gasket? Did you remove the old gasket? Did you use a sealant on the gasket? Did you accidentally disconnect a vaccum hose?
97Talonchik is offline   Reply With Quote
Old 03-08-2006, 04:47 PM   #3
carls47807
CF Freak
 
Join Date: Mar 2005
Location: new york
Posts: 582
sounds like it is flooding out. make sure thermos is in right as baxler said and make sure your coolant temp sensor connector is on well. any codes?
carls47807 is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Forum Jump



All times are GMT +1. The time now is 07:21 AM.

Powered by vBulletin Version 3.5.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 2002 - 2011 Car Forums. All rights reserved.