Car Forums  

Go Back   Car Forums > Technical Discussions > Repairs & Maintenance
FAQ Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 03-27-2007, 06:17 PM   #1
Ki2AY
CF's Pond Scum
 
Ki2AY's Avatar
 
Join Date: May 2004
Location: San Francisco CA.
Posts: 708
Popping noise after i installed my shocks + springs

I recently installed Koni yellow SHOCKS and Eiback sportline SPRINGS with rear camberkits on the 2002 rsx type s. (which gives me nearly a 2 inch drop)

Now as i drive im hearing this loud popping/clicking noise. it sounds like popcorn is being cooked in my trunk!
its definetly coming from the rear, and it seems as i speed up the noise becomes more rapid.

does anyone know that the cause of this is?
Ki2AY is offline   Reply With Quote
Old 03-27-2007, 06:55 PM   #2
nighthawk
Part Time Active User
 
nighthawk's Avatar
 
Join Date: Feb 2006
Location: -
Posts: 1,651
everything tightened properly?


sounds like something loose tapping and sort of bouncing around (ethier side to side or up and down)

but it really sounds strange
__________________

"There is a big difference between being fast and powerful and just being loud and annoying."
nighthawk is offline   Reply With Quote
Old 03-27-2007, 06:59 PM   #3
Ki2AY
CF's Pond Scum
 
Ki2AY's Avatar
 
Join Date: May 2004
Location: San Francisco CA.
Posts: 708
we've check everything, all screws were tight except...

the only thing we noticed that needed to be tightened was the screws that are in the tophat. but the noise was still there after it was done.

[edit]
ok, my friend who helped me install the shocks and springs said hes sure they werent installed upside down and also said that the springs cant slide of because its seated.

Last edited by Ki2AY : 03-27-2007 at 07:07 PM.
Ki2AY is offline   Reply With Quote
Old 03-27-2007, 07:38 PM   #4
V-Tec
CF's student post whore
 
Join Date: Sep 2005
Location: Chicago
Posts: 797
Quote:
Originally Posted by Ki2AY
we've check everything, all screws were tight except...

the only thing we noticed that needed to be tightened was the screws that are in the tophat. but the noise was still there after it was done.

[edit]
ok, my friend who helped me install the shocks and springs said hes sure they werent installed upside down and also said that the springs cant slide of because its seated.
i just had my neuspeed springs installed and i had the same issue... i took it back and they realized they forgot one of the bushings.
__________________
I always tell the truth,
even when i lie
V-Tec is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Forum Jump



All times are GMT +1. The time now is 11:08 AM.

Powered by vBulletin Version 3.5.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 2002 - 2011 Car Forums. All rights reserved.