Car Forums  

Go Back   Car Forums > Technical Discussions > Repairs & Maintenance
FAQ Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 09-06-2007, 12:13 AM   #1
dansshos
CF Newbie
 
Join Date: Sep 2007
Posts: 1
94 SHO (that damn light)

I have a 1994 taurus sho 3.2 auto with 116k on it. Beautiful in an out- but then there is that demonic orange "check engine" light. When it first came on about a6 months ago, a diagnostics check showed it to have a failed rear bank o2 sensor. I replaced both of them and the light went off. The car ran beautifully, averaging about 19 mpg in town and twice getting 31 to 32 in the open road.
Then recently, the light returned, and I found myself getting worse milage than my dads 87 burban 350. 12.3 :<. Again I diagnosed it and this time got codes for the same o2 sensor along with the EGR valve and MAF sensor. I payed out $57 for a new EGR valve, and put the MAF sensor off a wrecked 93 I have on it, and the light returned without change. SO this is the question I have for ANYONE who can help my sorry ass. I am guessing that the bad EGR valve caused the o2 sensor failure both times. The reason for this is 1. both times the o2 has failed 2. The location of the EGR- it is at the rear of the intake manifold which I believe would have fed excess amounts of exhaust gas to the rear cylinders first because they are closest to it. thus both times the REAR BANK o2 failed. Is this logical? please please please help me! I love this car more than women. I have 2 of them, my other is a 92 5 speed ( which I recently shattered the pressure plate in- accidentally shifting to 2nd instead of 4th from 3rd at 95mph is a bad idea). I find myself angry as hell at the ATX 94 and I just want it to run great again! So what I want to do is start by attempting to clean out that o2 sensor with brake cleaner and put it back in, or just pay out 60 bucks and get a new. What do u think people?
dansshos is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Forum Jump



All times are GMT +1. The time now is 06:14 AM.

Powered by vBulletin Version 3.5.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 2002 - 2011 Car Forums. All rights reserved.