Car Forums  

Go Back   Car Forums > Technical Discussions > Repairs & Maintenance
FAQ Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 09-07-2007, 11:42 PM   #1
indigogirls
CF Newbie
 
Join Date: Sep 2007
Posts: 1
Horn Doesn't Work

I have a chevy cavalier 2000, and a few months ago the horn stopped working. I got this car very cheap and the guy wasn't sure about the previous owner so there's not much for me to go on as for its history.

Ever since I bought it the airbag light has been on, and thi was about a year and a half ago. Just a few months ago the horn stopped working. The alarm also doesn't work, which I am assuming was the horn, too. About a month and a half ago it finally beeped once after i locked my car via the clicker, which is what it should do, but it hasn't since. How can I fix this, is it anything I can do myself? I do not know much about cars at all but I am interested in learning so please try to be as specific as possible.
indigogirls is offline   Reply With Quote
Old 09-20-2007, 07:20 PM   #2
jamfam
CF Newbie
 
jamfam's Avatar
 
Join Date: Sep 2007
Location: Canada
Posts: 12
fuse

Look in you owners manual and find out where the fuse is located, then check it. if you don't know how im sure one of your friends does.
jamfam is offline   Reply With Quote
Old 09-21-2007, 05:42 PM   #3
cmeseadoin
CF Freak
 
Join Date: Jun 2003
Location: Richmond, Virginia
Posts: 596
Quote:
Originally Posted by indigogirls
I do not know much about cars at all but I am interested in learning so please try to be as specific as possible.

In your request for people on this forum to be specific, we would need you to do the same thing before we are able/interested in assisting. What is a Cavalier 2000, I am unaware of such a model. Would this be a year 2000 Chevrolet Cavalier instead? If so, what engine and transmission options do you have? We need people to be in the habbit of providing ALL details of an issue before they can expect help. Hence, the correct terminology on a technical matter always helps to acsertain a technical answer.

Second of all, I am unaware that Chevrolet installed a factory alarm system on one of the lowest end models they make, a Cavalier. I could be wrong. Is this a factory alarm system or aftermarket installed by someone else? Maybe you got it cheap for a reason? I really have no idea what you are facing since I do not know what alarm is in the car or the way it is wired. I would advise you off the bat to check in your owners manual and see if there is ANY reference to ALARM in there or FUSES that report a connectino with an alarm system. If not, you're dealing with someone else's garbage that was probably hap-hazzardly installed by a fly by night individual. If there IS a ref. to an alarm, check all fuses to it as well as you need to check the HORN fuse and circuit. So, when you depress the steering wheel airbag module in the car, the horn will not work at all...ever? Give us more info. to help us help you!

Quote:
Originally Posted by indigogirls
Ever since I bought it the airbag light has been on, and thi was about a year and a half ago. Just a few months ago the horn stopped working. The alarm also doesn't work, which I am assuming was the horn, too.

This suggest you might have a deeper issue, or maybe not. I have no idea. Have you had the shop scan the air bag SRS system to see what the fault is? That is the first thing to do when you have an airbag light on. If that light is on, you could have a major issue with the SRS system in the car! Your airbags might not even work if there is a problem. You need to have that checked to determine what is wrong. I cannot, nor can anyone run a crystall ball and tell you, it will require someone with knowledge to scan and pull codes.
__________________
2006 Mazdaspeed6, 2002 Pontiac Trans AM Ram Air WS-6, 1996 Jeep Cherokee Sport 4x4, 2002 Durango 5.9 R/T, 1995 Jeep Cherokee Sport 4x4, 1994 Ford Taurus SHO 3.2L, 1976 Buick 225 Limited, 1992 Miata, 2008 Miata.

Other toys: 2003 Honda Superhawk 996 sportbike, 2007 Suzuki M109R cruiser, 2006 Kawasaki KLR 650, 1996 and 1997 Sea Doo GSX limited watercraft.
cmeseadoin is offline   Reply With Quote
Old 09-30-2007, 06:27 AM   #4
dodger65
I know more than Wally...
 
dodger65's Avatar
 
Join Date: Apr 2005
Location: U.S. - Midwest
Posts: 2,117
Quote:
Originally Posted by cmeseadoin
What is a Cavalier 2000, I am unaware of such a model.

it's a broom, cme... like in harry potter... it's the model that superseded the nimbus 2000... duh!
__________________
"Everyone is someone else's weirdo"

dodger65 is offline   Reply With Quote
Old 10-01-2007, 05:41 PM   #5
cmeseadoin
CF Freak
 
Join Date: Jun 2003
Location: Richmond, Virginia
Posts: 596
Quote:
Originally Posted by dodger65
it's a broom, cme... like in harry potter... it's the model that superseded the nimbus 2000... duh!

Is THAT what it is!!?? I have not read any Harry Potter books nor seen any movies, but I will trust you on that one!
__________________
2006 Mazdaspeed6, 2002 Pontiac Trans AM Ram Air WS-6, 1996 Jeep Cherokee Sport 4x4, 2002 Durango 5.9 R/T, 1995 Jeep Cherokee Sport 4x4, 1994 Ford Taurus SHO 3.2L, 1976 Buick 225 Limited, 1992 Miata, 2008 Miata.

Other toys: 2003 Honda Superhawk 996 sportbike, 2007 Suzuki M109R cruiser, 2006 Kawasaki KLR 650, 1996 and 1997 Sea Doo GSX limited watercraft.
cmeseadoin is offline   Reply With Quote
Old 11-10-2007, 08:43 PM   #6
Spartan3c79
CF Newbie
 
Join Date: Nov 2007
Posts: 19
Horn

I had the same problem with horn not working in my moms car . . it clicked when i hit the botton for the horn . . . i replaced the fuse and now it works . . . love them fuses!
Spartan3c79 is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Forum Jump



All times are GMT +1. The time now is 08:14 AM.

Powered by vBulletin Version 3.5.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 2002 - 2011 Car Forums. All rights reserved.