Car Forums  

Go Back   Car Forums > Technical Discussions > Repairs & Maintenance
FAQ Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 10-01-2007, 02:17 AM   #1
livingearth
CF Newbie
 
Join Date: Oct 2007
Posts: 6
92' Ford F150 No Spark

I have a 1992 F150 that died suddenly last week.
It had no spark. I have changed out the TFI module on the sidewall.
The coil, plugs, wires, cap and rotor and the distributor with new parts but still no fire. I honestly do not know where to look from here. Any ideas?

Last edited by livingearth : 10-01-2007 at 02:52 AM.
livingearth is offline   Reply With Quote
Old 10-01-2007, 04:46 PM   #2
glagon1979
daddy x3
 
glagon1979's Avatar
 
Join Date: Jan 2005
Location: back in Williamson, NY
Posts: 1,101
ENGINE SIZE? could be ECU. dont quote me on it but judging by what you have replaced..........
__________________
this forum is to dead to share a cool sig with everybody....
glagon1979 is offline   Reply With Quote
Old 10-01-2007, 07:02 PM   #3
livingearth
CF Newbie
 
Join Date: Oct 2007
Posts: 6
Engine size...

The engine is an 8 cyl 5.0 (302)...
Where on this model would the ECM be located?
livingearth is offline   Reply With Quote
Old 10-01-2007, 09:39 PM   #4
67Coronet383
CF Riff Master
 
67Coronet383's Avatar
 
Join Date: Nov 2005
Location: Under a hood, Georgia
Posts: 628
Ignition module on a lot of 5.0s are known to go bad.
__________________
67Coronet383 is offline   Reply With Quote
Old 10-02-2007, 01:25 AM   #5
What
Banned
 
Join Date: Jul 2004
Location: Costa Nocha
Posts: 652
Quote:
Originally Posted by 67Coronet383
Ignition module on a lot of 5.0s are known to go bad.

You have no idea what you're talking about.
What is offline   Reply With Quote
Old 10-02-2007, 02:55 AM   #6
67Coronet383
CF Riff Master
 
67Coronet383's Avatar
 
Join Date: Nov 2005
Location: Under a hood, Georgia
Posts: 628
Quote:
Originally Posted by What
You have no idea what you're talking about.
LOL. Dumbass.

There was a recall on it. The ignition modules were mounted on the distributors and overheated and failed IIRC. I've replaced many of them for this reason.

STFU you worthless shit face.
__________________
67Coronet383 is offline   Reply With Quote
Old 10-02-2007, 06:51 PM   #7
cmeseadoin
CF Freak
 
Join Date: Jun 2003
Location: Richmond, Virginia
Posts: 596
Quote:
Originally Posted by 67Coronet383
LOL. Dumbass.
There was a recall on it. The ignition modules were mounted on the distributors and overheated and failed IIRC. I've replaced many of them for this reason.
STFU you worthless shit face.


You tell 'em!!! I love to watch the b_tch slapping and IDIOT calling out!! You are 100% correct from what I can find and he's already basically replaced MOST ignition contents except he makes no mention of the ignition module. That would make sense to check all of that and furthermore, all "WHAT" could tell us was that YOU have no idea what you're talking about! Why don't you tell us what you know WHAT? Truth be known, you evidentally don't know sh_t!!?? Do you know what an ignition module is WHAT? and a Where are your suggestions, up your pooper with your brain??? Yeah, guess what, I'm me and F'n GLAD I'm NOT you! (based off your worthless sig)
__________________
2006 Mazdaspeed6, 2002 Pontiac Trans AM Ram Air WS-6, 1996 Jeep Cherokee Sport 4x4, 2002 Durango 5.9 R/T, 1995 Jeep Cherokee Sport 4x4, 1994 Ford Taurus SHO 3.2L, 1976 Buick 225 Limited, 1992 Miata, 2008 Miata.

Other toys: 2003 Honda Superhawk 996 sportbike, 2007 Suzuki M109R cruiser, 2006 Kawasaki KLR 650, 1996 and 1997 Sea Doo GSX limited watercraft.
cmeseadoin is offline   Reply With Quote
Old 10-02-2007, 06:54 PM   #8
cmeseadoin
CF Freak
 
Join Date: Jun 2003
Location: Richmond, Virginia
Posts: 596
Quote:
Originally Posted by What
You have no idea what you're talking about.


Oh wait, this is what WHAT's public profile displays: Occupation:
Inner City Gangster....doesn't that tell you ALL you need to know 67Coronet383?? I sure FILLS IN ALL THE BLANKS for me!
__________________
2006 Mazdaspeed6, 2002 Pontiac Trans AM Ram Air WS-6, 1996 Jeep Cherokee Sport 4x4, 2002 Durango 5.9 R/T, 1995 Jeep Cherokee Sport 4x4, 1994 Ford Taurus SHO 3.2L, 1976 Buick 225 Limited, 1992 Miata, 2008 Miata.

Other toys: 2003 Honda Superhawk 996 sportbike, 2007 Suzuki M109R cruiser, 2006 Kawasaki KLR 650, 1996 and 1997 Sea Doo GSX limited watercraft.
cmeseadoin is offline   Reply With Quote
Old 10-02-2007, 10:26 PM   #9
obrienjaj
CF Newbie
 
Join Date: Sep 2007
Posts: 5
I had this problem a long time ago

I am not a mechanic and I had to deal with this problem at least 10 yrs ago. Meaning I don't know the correct names and such and I think that yours is the same engine I was dealing with.

I checked the coil and wires and everthing I could think of in the system but could not find the problem. I described the problem to an old man at parts store I called at random and he told me what to do.

Under the distributor cap was a plate that lifted off. There was a circuit board in there that went bad. He handed me a new one a tube of electrical grease and 10 minutes after I got back home and about $20 later the car was running great.
obrienjaj is offline   Reply With Quote
Old 10-02-2007, 11:50 PM   #10
dodger65
I know more than Wally...
 
dodger65's Avatar
 
Join Date: Apr 2005
Location: U.S. - Midwest
Posts: 2,117
make sure you have +12v to the positive side of the coil w/ the key in the run position as well...
__________________
"Everyone is someone else's weirdo"

dodger65 is offline   Reply With Quote
Old 10-03-2007, 01:25 AM   #11
livingearth
CF Newbie
 
Join Date: Oct 2007
Posts: 6
Present Status...

Thanks to all for your contribution...
Here s my present status...

At present I still have no fire...

I have replaced the following items with new parts...
Ignition Coil
Spark Plugs
Spark Plug and Coil wires
ICM ( Ignition Control Module previously called a TFI on models where it was mounted on distributor)
Distributor Cap and Rotor
Distributor w/PIP

I do have 12 VDC at the positive side of the coil when the ignition is in the on position

When I appliy a test light to the neg side of the coil and to ground it lights up ( on position) When I turn over the engine light remains on but no noticeable flashing.

When I measure cotinueity between the neg coil connector of the wire harness ( disconnected) and the #2 socket of the ICM harness connector It measures almost zero resistance.

There is no stray voltage present at the #2 socket....

resistance from the neg coil terminal and ground is reading about .391 Meg Ohms

I thought these readings to be good but still no fire....
livingearth is offline   Reply With Quote
Old 10-03-2007, 02:17 AM   #12
dodger65
I know more than Wally...
 
dodger65's Avatar
 
Join Date: Apr 2005
Location: U.S. - Midwest
Posts: 2,117
you replaced the entire distributor? am i reading that correctly? this may seem stupid, but just for the hell of it, make sure the dist is turning... one of my friends had a few dist gear/cam issues a while back and sometimes it's the ridiculous things that can stump you...

ps: testing the neg on the coil would probably work better if you unhook the neg from the coil and go from +12v to the neg coil wire... it sounds like you're getting +12v through the coil windings
__________________
"Everyone is someone else's weirdo"


Last edited by dodger65 : 10-03-2007 at 02:21 AM.
dodger65 is offline   Reply With Quote
Old 10-03-2007, 03:49 PM   #13
What
Banned
 
Join Date: Jul 2004
Location: Costa Nocha
Posts: 652
Quote:
Originally Posted by cmeseadoin
Yeah, guess what, I'm me and F'n GLAD I'm NOT you! (based off your worthless sig)

Who are you? I've never read you before...but you have 500+ posts. You've impacted nothing.

YOU shut the f*ck up.
WE forget.

It's a you-we situation.
What is offline   Reply With Quote
Old 10-03-2007, 07:30 PM   #14
cmeseadoin
CF Freak
 
Join Date: Jun 2003
Location: Richmond, Virginia
Posts: 596
Quote:
Originally Posted by What
Who are you? I've never read you before...but you have 500+ posts. You've impacted nothing.

YOU shut the f*ck up.
WE forget.

It's a you-we situation.

....and you've got over 760 + posting. Everything on the first couple of pages is ABSOLUTELY nothing neither technical nor special. Have you typed ONE single TECHNICAL posting or thread on here dick stick? I think the answer is NO!! You're a stupid kid with nothing more to do than log onto a forum and talk about COOOOOL CARS and BULLshit! It's not worth my time to dig any deeper into you. I'm sure all of your psycho-babble on here is BULLSHIT, asswipe!

You don't know shit about anything, you've proven that. Enthrall us some more with your technical knowledge why don't you. All you do is stick your worthless comments in places they are not needed nor wanted. Your screename says it all! WHAT? Yeah, that's right, because you consist of about 90% water and 10% pure horse shit! Why don't you IMPACT yourself and stick your head up your fukin' ass pussy boy! Or should I say GANGSTA like your profile you PIECE OF SHIT! You're probably and stupid as the day is long. I can SEE it now! Guess "WHAT??," I have a BIG PHAT "Go fu_k yourself" for ya!

Here’s how smart you are you dumb asshole... Straight from your profile itself:

“Blunt to my...lips. Gun on my...hip. Rocks in my...socks. Pockets full of...grip.”

GO KILL YOURSELF you “Inner City Gangster!!” POS
__________________
2006 Mazdaspeed6, 2002 Pontiac Trans AM Ram Air WS-6, 1996 Jeep Cherokee Sport 4x4, 2002 Durango 5.9 R/T, 1995 Jeep Cherokee Sport 4x4, 1994 Ford Taurus SHO 3.2L, 1976 Buick 225 Limited, 1992 Miata, 2008 Miata.

Other toys: 2003 Honda Superhawk 996 sportbike, 2007 Suzuki M109R cruiser, 2006 Kawasaki KLR 650, 1996 and 1997 Sea Doo GSX limited watercraft.

Last edited by Cliffy : 10-04-2007 at 01:22 AM.
cmeseadoin is offline   Reply With Quote
Old 10-04-2007, 12:45 AM   #15
dodger65
I know more than Wally...
 
dodger65's Avatar
 
Join Date: Apr 2005
Location: U.S. - Midwest
Posts: 2,117
Quote:
Originally Posted by cmeseadoin
....and you've got over 760 + posting. Everything on the first couple of pages is ABSOLUTELY nothing neither technical nor special. Have you typed ONE single TECHNICAL posting or thread on here dick stick? I think the answer is NO!! You're a stupid kid with nothing more to do than log onto a forum and talk about COOOOOL CARS and BULLshit! It's not worth my time to dig any deeper into you. I'm sure all of your psycho-babble on here is BULLSHIT, asswipe!

You don't know shit about anything, you've proven that. Enthrall us some more with your technical knowledge why don't you. All you do is stick your worthless comments in places they are not needed nor wanted. Your screename says it all! WHAT? Yeah, that's right, because you consist of about 90% water and 10% pure horse shit! Why don't you IMPACT yourself and stick your head up your fukin' ass pussy boy! Or should I say GANGSTA like your profile you PIECE OF SHIT! You're probably a white and stupid as the day is long. I can SEE it now! Guess "WHAT??," I have a BIG PHAT "Go fu_k yourself" for ya!

Here’s how smart you are you dumb asshole... Straight from your profile itself:

“Blunt to my...lips. Gun on my...hip. Rocks in my...socks. Pockets full of...grip.”

GO KILL YOURSELF you “Inner City Gangster!!” POS

are you talking to yourself, cme?
__________________
"Everyone is someone else's weirdo"


Last edited by Cliffy : 10-04-2007 at 01:23 AM.
dodger65 is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Forum Jump



All times are GMT +1. The time now is 12:35 PM.

Powered by vBulletin Version 3.5.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright © 2002 - 2011 Car Forums. All rights reserved.