Car Forums  

Go Back   Car Forums > Technical Discussions > Repairs & Maintenance
FAQ Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 01-17-2008, 02:49 AM   #1
ryano
CF Newbie
 
Join Date: Jan 2008
Posts: 1
Need help with 4Runner

I have a '91 Toyota 4Runner, that revs up and down while idling. Also, while I'm driving, if I try to hold a constant pressure on the gas pedal.. the truck will "jump" or "buck". But when I am speeding up, (or not giving it gas at all) it will drive smoothly. Every once in a while the 'check engine' light will come on. The gas is just being eaten up, and I can smell fuel when I'm staying still.. I think from the exhaust. Anyone have any ideas on what is going on? I thought maybe the TPS was causing the jumping and revving, but when i unplugged it, there was no change. Also, I was curious if a bad O2 sensor could be causing the fuel to be used so quickly and have to do with the smell of fuel. I haven't tried replacing that yet, I just wanted to get any ideas before I went to pick up some new parts. Thanks in advance!
ryano is offline   Reply With Quote
Old 02-10-2008, 11:04 PM   #2
DARKtEAGLE
CF Addict
 
DARKtEAGLE's Avatar
 
Join Date: Feb 2008
Location: williamsport,PA
Posts: 277
Quote:
Originally Posted by ryano
I have a '91 Toyota 4Runner, that revs up and down while idling. Also, while I'm driving, if I try to hold a constant pressure on the gas pedal.. the truck will "jump" or "buck". But when I am speeding up, (or not giving it gas at all) it will drive smoothly. Every once in a while the 'check engine' light will come on. The gas is just being eaten up, and I can smell fuel when I'm staying still.. I think from the exhaust. Anyone have any ideas on what is going on? I thought maybe the TPS was causing the jumping and revving, but when i unplugged it, there was no change. Also, I was curious if a bad O2 sensor could be causing the fuel to be used so quickly and have to do with the smell of fuel. I haven't tried replacing that yet, I just wanted to get any ideas before I went to pick up some new parts. Thanks in advance!

my father had the same problem wit a bronco 2 so i checked and replaced all the esentials like( coil, spark plugs,spark plug wires,distributer and cap, fuel regulater, and cloged air filter lol) but the same problem still occured. so pondered about online looking for info an i found this site. i sat back dumbfounded for a min. they said replace the 02 sensor. so i did and the bronco runs great. plus i even gain some of his MPG's back. so yeah 02 sensor work for me. so it would prolly work for u. so good luck
__________________



92% of teens moved on to rap music.
If you're part of the 8% that rock out everyday, put this in your signature
DARKtEAGLE is offline   Reply With Quote
Old 02-11-2008, 12:25 AM   #3
tbaxleyjr
CF Extraordinaire
 
Join Date: Mar 2004
Location: Somewhere in the Southeastern U.S.
Posts: 1,067
replacing the O2 sensor will work if the O2 sensor is bad.

Since the check engine light is on, have you found out what codes are being thrown before buying parts? - Normally when it comes on or flashes on and off when driving, there is a reason it is on.
tbaxleyjr is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Forum Jump



All times are GMT +1. The time now is 05:13 AM.

Powered by vBulletin Version 3.5.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 2002 - 2011 Car Forums. All rights reserved.