Car Forums  

Go Back   Car Forums > Technical Discussions > Repairs & Maintenance
FAQ Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 10-12-2008, 04:02 PM   #1
jzar
CF Newbie
 
Join Date: Oct 2008
Posts: 1
98 regal ?'s

First question: My front turn signals do not blink, they constantly remain on when I use them, what gives?

#2: Any idea why the odometer and trip reads "Error"?
jzar is offline   Reply With Quote
Old 10-13-2008, 05:07 AM   #2
Satty101
CF's L body Freak
 
Satty101's Avatar
 
Join Date: Sep 2003
Location: Colorado Springs CO
Posts: 2,865
Quote:
Originally Posted by jzar
First question: My front turn signals do not blink, they constantly remain on when I use them, what gives?

#2: Any idea why the odometer and trip reads "Error"?



The turn signals could be a burnt out flasher relay. It's under the steering column. It should click on and off.


As far as the odo and trip...I actually don't know. I've never delt with that before.
__________________
My cars:

1999 Chevrolet Camaro SS (PC'd)
1994 Chevrolet Beretta Z26 Q4 (W41 M90'd)
2004 Chevrolet Silverado 2500 (4WD)

My wife's cars:

1971 Dodge Charger SE (stock and original 383 auto)
2004 Subaru Impreza WRX (kid-hauler)
Satty101 is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Forum Jump



All times are GMT +1. The time now is 03:49 AM.

Powered by vBulletin Version 3.5.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 2002 - 2011 Car Forums. All rights reserved.