Car Forums  

Go Back   Car Forums > Technical Discussions > Repairs & Maintenance
FAQ Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 10-16-2008, 12:57 AM   #1
flatbmx1
CF Newbie
 
Join Date: Oct 2008
Posts: 4
94 toyota celica doesnt start in hot weather

I have a 94 toyota celica gt and it wont start in hot weather. Usually all I would have to do is open the doors and let the car air out and it would start up but recently it has not been starting at all. I replaced the fuel pump and it seemed to fix the problem for about a week but now is back to doing the same thing. Does anyone know what the problem is?
flatbmx1 is offline   Reply With Quote
Old 10-16-2008, 04:27 AM   #2
Satty101
CF's L body Freak
 
Satty101's Avatar
 
Join Date: Sep 2003
Location: Colorado Springs CO
Posts: 2,865
wait, you opened the cabin doors let it air out and it would start? I'm pretty sure that's just coincidence...
__________________
My cars:

1999 Chevrolet Camaro SS (PC'd)
1994 Chevrolet Beretta Z26 Q4 (W41 M90'd)
2004 Chevrolet Silverado 2500 (4WD)

My wife's cars:

1971 Dodge Charger SE (stock and original 383 auto)
2004 Subaru Impreza WRX (kid-hauler)
Satty101 is offline   Reply With Quote
Old 10-16-2008, 04:49 AM   #3
flatbmx1
CF Newbie
 
Join Date: Oct 2008
Posts: 4
no its not it has worked multiple times
when I get in my car and its really hot i know for sure its not going to start
flatbmx1 is offline   Reply With Quote
Old 10-16-2008, 08:24 AM   #4
DBain
CF Enthusiast
 
DBain's Avatar
 
Join Date: Apr 2008
Location: Boonies of NH
Posts: 195
Sounds a little too far fetched for me. The only thing in relation I can think of is an ign switch(that is if it wont turn over either).
However if it does turn over but not start and replacing the fuel pump helped, I'd lean towards a fuel filter.
Knowing if it'll turn over or not would be some helpful info at this point.
__________________
2000 Acura Integra LS
B18B1 1.8L 4cyl
2dr Coupe

1987 Chevy Scotsdale
350CI TBI 4sp Auto 2WD
2dr Std Cab Short Bed
DBain is offline   Reply With Quote
Old 10-16-2008, 10:26 PM   #5
flatbmx1
CF Newbie
 
Join Date: Oct 2008
Posts: 4
well i also replaced the fuel filter when i did the pump
and it does turn over. what happens is the car will start up but then die immediately. so idk whats wrong
flatbmx1 is offline   Reply With Quote
Old 10-17-2008, 12:46 AM   #6
Satty101
CF's L body Freak
 
Satty101's Avatar
 
Join Date: Sep 2003
Location: Colorado Springs CO
Posts: 2,865
Sounds like a fuel pressure regulator...What engine do you have?
__________________
My cars:

1999 Chevrolet Camaro SS (PC'd)
1994 Chevrolet Beretta Z26 Q4 (W41 M90'd)
2004 Chevrolet Silverado 2500 (4WD)

My wife's cars:

1971 Dodge Charger SE (stock and original 383 auto)
2004 Subaru Impreza WRX (kid-hauler)
Satty101 is offline   Reply With Quote
Old 10-17-2008, 03:33 AM   #7
flatbmx1
CF Newbie
 
Join Date: Oct 2008
Posts: 4
its a 2.2 liter
flatbmx1 is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Forum Jump



All times are GMT +1. The time now is 03:10 PM.

Powered by vBulletin Version 3.5.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 2002 - 2011 Car Forums. All rights reserved.