Car Forums  

Go Back   Car Forums > Technical Discussions > Repairs & Maintenance
FAQ Search Today's Posts Mark Forums Read

Thread Tools Search this Thread Display Modes
Old 12-05-2008, 09:39 PM   #1
CF Newbie
Join Date: Dec 2008
Posts: 1
1999 Buick Regal HVAC issues

I have a 1999 Buick Regal that has a strange problem. Sometimes no air will come out any vents, either using the AC or Heat. When I turn on the lets say the ac, you here like its on, but no air. Its the same way for the heat.

1. Does the air conditioner use the blower like the heat does?

I have also noticed the when I use heat only, there blower motor seems to make a funny sound, like a squikey noise.

2. Could I have 2 problems as in the control module and blower, or can the blower cause all these problems?

I really appreciate any help on this issue. Thank you.
Painter is offline   Reply With Quote
Old 12-07-2008, 09:17 AM   #2
CF Enthusiast
DBain's Avatar
Join Date: Apr 2008
Location: Boonies of NH
Posts: 195
From personal experience, I'd say take the blower motor out (usually under or behind the glove box) and clean out any crap that may be in there. I knew a lady with a newer camry, and she complained about no heat and the fans making a weird noise. She bought a new blower motor but we ended up just cleaning out her old one (looked like a mouse nest inside) and it worked just fine. Had full heat and the noise went away. Not saying thats it, but it only took about 30min all together and cost no money, worth a shot.
2000 Acura Integra LS
B18B1 1.8L 4cyl
2dr Coupe

1987 Chevy Scotsdale
350CI TBI 4sp Auto 2WD
2dr Std Cab Short Bed
DBain is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Forum Jump

All times are GMT +1. The time now is 08:40 AM.

Powered by vBulletin Version 3.5.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 2002 - 2011 Car Forums. All rights reserved.