Car Forums  

Go Back   Car Forums > Technical Discussions > Repairs & Maintenance
FAQ Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 02-07-2009, 12:56 PM   #1
mikencrystald
CF Newbie
 
Join Date: Feb 2009
Location: Timberlake,NC
Posts: 1
Timing problems with a 92 eagle talon

I am very familiar with this year DSM,but I think that someone swapped the motor in it with one from a Turbo 95-96 range. The timing marks on the Crank Flange point at about 11 o'clock. The keyway is at 9 o'clock with a roll pin at 3 o'clock. The oil pump arrows were not aligned when I took the cover off to inspect it,but I don't think that would cause it to run like it did. It was hard to start and then once started, the idle would drop about 300rpm speratically.It would never shut off,but just idle funny. The new plugs I put in it were black on the tips. The head is definitely not a turbo head(I think) because when it is aligned, it has the dowel pins at the top at 12 o 'clock. I am thinking someone swapped the motor kept the same head. Also, I looked at pictures of tensioners and the one that is on mine has 1 bolt on both sides and not on the same side. Any help would be greatly appreciated.
mikencrystald is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Forum Jump



All times are GMT +1. The time now is 02:43 AM.

Powered by vBulletin Version 3.5.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 2002 - 2011 Car Forums. All rights reserved.