Car Forums  

Go Back   Car Forums > Vehicle Specific > Domestic Cars
FAQ Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 06-23-2009, 11:59 PM   #1
cpchase
CF Newbie
 
cpchase's Avatar
 
Join Date: Sep 2007
Posts: 27
Question The Poor Old Ford :(

I have a weird thing happening with my Crown Victoria LTD... I have tried so many thing to fix I have given up.

When Shifting into Rev or Drive the RPM drop low... sometimes enough to stall. This is even worst when turning while shifting. The other problem is when slowing down / braking the RPM will go up and down by a couple 100 RPM, making the car shake. Sometimes when at a complete stop ( ONLY WHEN ITS WARM OUT ) it will start with its funny RPM games and stall.

I've checked the tranny, computer, spark plugs, throttle body and vacume lines...

Any idea please help... lol

Ford Crown Victoria LTD 1990 Fuel Injected 302 5.0 L Auto Tranny.
__________________
Every King Needs His Crown
cpchase is offline   Reply With Quote
Old 06-24-2009, 12:53 AM   #2
corbett_auto
CF Addict
 
corbett_auto's Avatar
 
Join Date: Oct 2004
Location: just west of Charlotte, NC
Posts: 448
Sounds like a bad vacuum leak. Maybe even a busted diaphragm in the brake booster. Hook a vacuum pump to the booster and see if it can hold a vacuum.
__________________
corbett_auto is offline   Reply With Quote
Old 06-24-2009, 03:05 AM   #3
cpchase
CF Newbie
 
cpchase's Avatar
 
Join Date: Sep 2007
Posts: 27
ok will check that... maybe Idle Air Control ?
__________________
Every King Needs His Crown
cpchase is offline   Reply With Quote
Old 12-31-2010, 11:42 AM   #4
jklasd
CF Newbie
 
Join Date: Nov 2010
Posts: 1
Same problem

Quote:
Originally Posted by cpchase
I have a weird thing happening with my Crown Victoria LTD... I have tried so many thing to fix I have given up.

When Shifting into Rev or Drive the RPM drop low... sometimes enough to stall. This is even worst when turning while shifting. The other problem is when slowing down / braking the RPM will go up and down by a couple 100 RPM, making the car shake. Sometimes when at a complete stop ( ONLY WHEN ITS WARM OUT ) it will start with its funny RPM games and stall.

I've checked the tranny, computer, spark plugs, throttle body and vacume lines...

Any idea please help... lol

Ford Crown Victoria LTD 1990 Fuel Injected 302 5.0 L Auto Tranny.


I also found it but it is not actually mistake, in my concern its due to spare parts which actually not fit for the car model........
jklasd is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Forum Jump



All times are GMT +1. The time now is 03:47 PM.

Powered by vBulletin Version 3.5.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 2002 - 2011 Car Forums. All rights reserved.