Car Forums  

Go Back   Car Forums > Technical Discussions > Repairs & Maintenance
FAQ Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 11-03-2004, 10:38 PM   #1
ccrigler
CF Newbie
 
Join Date: Nov 2004
Posts: 1
Galant won't shift into park

I own a 1993 Mitsubishi Galant, 4-door, 4-cylinder, automatic transmision. I know very little about transmissions. My problem is after driving about an hour I pull into gas station and shifter will not go into park. It never had problems before. (I did remember that underside front of car hit/scraped on a steep driveway I backed out of on that trip...at the time it didn't seem like a severe bottoming out.)

I asked a mechanic about it & he thought problem would be in the shifter inside the car, I took it apart, detached shifter from cable/rod that goes to transmission. The rod would not push into the park position, it shifted to all other gears fine, but could not even be forced into park. Can anyone help? Any thoughts?

I can force it enough to release the key, but the transmission does not go into park.
ccrigler is offline   Reply With Quote
Old 11-23-2004, 03:28 PM   #2
barretire
CF Newbie
 
Join Date: Nov 2004
Posts: 56
linkage

Quote:
Originally Posted by ccrigler
I own a 1993 Mitsubishi Galant, 4-door, 4-cylinder, automatic transmision. I know very little about transmissions. My problem is after driving about an hour I pull into gas station and shifter will not go into park. It never had problems before. (I did remember that underside front of car hit/scraped on a steep driveway I backed out of on that trip...at the time it didn't seem like a severe bottoming out.)

I asked a mechanic about it & he thought problem would be in the shifter inside the car, I took it apart, detached shifter from cable/rod that goes to transmission. The rod would not push into the park position, it shifted to all other gears fine, but could not even be forced into park. Can anyone help? Any thoughts?

I can force it enough to release the key, but the transmission does not go into park.
Try adjusting your linkage
__________________
<link removed>
barretire is offline   Reply With Quote
Old 12-15-2005, 09:32 AM   #3
veritedefolie
CF Newbie
 
Join Date: Dec 2005
Posts: 1
I just got the same problem following hitting a curb, frontal underside collision.
Did you find a way to easily fix it? If not, anyone else have suggestions?

Thanks,
Dima
veritedefolie is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Forum Jump



All times are GMT +1. The time now is 04:53 AM.

Powered by vBulletin Version 3.5.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 2002 - 2011 Car Forums. All rights reserved.