Car Forums  

Go Back   Car Forums > Technical Discussions > Repairs & Maintenance
FAQ Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 01-27-2005, 03:01 PM   #1
dianwill1
CF Newbie
 
Join Date: Jan 2005
Posts: 1
1986 corvette upshift light

I have a 1986 Corvette, OEM engine. It has the 4007r tranny, and 5.7 engine, with about 193000 miles on it. The problem is lately the upshift light is coming on at various cruising speeds. I take my foot off the pedal a few and it goes away. I am not sure what is causing it, but have taken it to the dealership to resovle other issues. Many parts repaired. Any suggestions as to where I might look for the reason this light comes on? I have had the transmission serviced, and adjusted. The car flys!

One additional problem, the heater blower doesn't seem to work correctly. The air is small mass amount and then will function right. Heat works just fine. Could it be the blower motor, or the heater core?


Any suggestions for me to hunt for the defective parts would help before I have to take it back to the dealership for repairs. I have spent too much already keeping up on this commuter car... but it drives fine. And no, I won't take it to an aftermarket shop for repairs except standard repairs. The last shop roked me, and forgot to replace parts and broke parts when I got it back. okay, I'm stopping ranting now.. ;o)

brb
dianwill1 is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Forum Jump



All times are GMT +1. The time now is 07:03 AM.

Powered by vBulletin Version 3.5.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 2002 - 2011 Car Forums. All rights reserved.