Car Forums  

Go Back   Car Forums > Technical Discussions > Repairs & Maintenance
FAQ Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
Old 02-15-2005, 11:42 PM   #1
Centralia62801
Banned
 
Join Date: Feb 2005
Posts: 1
91 Chevy Beretta V6-3.1L(Overheating)

I'm Lisa,
I recently had my car's engine repaired. I had a new water pump, new thermostat, radiator flushed and I even had the heads grinded.

It still is over heating, Can anyone help? I heard that the thermostats have known to be bad in a 91 beretta but I don't see how.

That made nos ense when I heard it. I've bought 2 thermostats and it over heats, It takes a while for it to over heat but when it does it refuses to start up after I stop it.

It seems to lose water somewhere but I can not seem to find a leak anywhere unless it is hitting the engine and evaporating.


I really love my beretta and it has sooo much power I refuse to sell it but I'm afraid to take it back to that mechanic. "he's supossedly the best"

It did not do this until I took it to a different mechanic which he was messing with the belt tensioner..

The tensioner has directions on which way to loosen or tighten it and he went the wrong way and it snapped the bolt, After that it started over heating badly.

Sorry for such a long post "looks like a mess" but besides running back and forth trying to fix the car and searching the net for options I'm just tired :P
Centralia62801 is offline   Reply With Quote
Old 02-16-2005, 12:39 AM   #2
carlos
CF Addict
 
Join Date: Feb 2005
Posts: 273
heads grinded? how much did you pay for that?
for the overheating problem possible air trapped in your sys.
carlos is offline   Reply With Quote
Old 02-16-2005, 02:18 AM   #3
BanffAutoSpa_ap
Pants The Ripper
 
BanffAutoSpa_ap's Avatar
 
Join Date: Jan 2005
Location: Southern Alberta Likes:Long walks on the beach.....after anal
Posts: 1,510
well first off you have to have a cooling system that doesn't leak(coolant or water or whatever you put in it) if the system can hold pressure than it can only be a couple of things
1. thermostat(which you've already replaced)
2 radiator cooling fans not working( either the fan itself or a relay or a sensor that tells the fan when to come on could be FUBAR)
3. not getting proper flow through your cooling system( maybe water pump turning the wrong way, rare but it happens if someone installs the wrong pump. a plugged cooling system but you've had that flushed you said)
4. proper air flow through the rad( maybe a whole lotta crap stuck in the rad not letting air to flow through the cooling fins)
5. could also be the gauge or sensor for the gauge not reading properly.
6. or like carlos said you could have an air lock but i think those berettas have a bleed valve so if the mechanic knew what he was dooing then he woulda bled the cooling system of air

if anyone has any others let Lisa know.
__________________
Despite the high cost of living, it remains very popular.
BanffAutoSpa_ap is offline   Reply With Quote
Old 02-16-2005, 01:21 PM   #4
srober32
CF Addict
 
srober32's Avatar
 
Join Date: Feb 2005
Location: Detroit, Michigan
Posts: 442
Quote:
Originally Posted by BanffAutoSpa_ap
well first off you have to have a cooling system that doesn't leak(coolant or water or whatever you put in it) if the system can hold pressure than it can only be a couple of things
1. thermostat(which you've already replaced)
2 radiator cooling fans not working( either the fan itself or a relay or a sensor that tells the fan when to come on could be FUBAR)
3. not getting proper flow through your cooling system( maybe water pump turning the wrong way, rare but it happens if someone installs the wrong pump. a plugged cooling system but you've had that flushed you said)
4. proper air flow through the rad( maybe a whole lotta crap stuck in the rad not letting air to flow through the cooling fins)
5. could also be the gauge or sensor for the gauge not reading properly.
6. or like carlos said you could have an air lock but i think those berettas have a bleed valve so if the mechanic knew what he was dooing then he woulda bled the cooling system of air

if anyone has any others let Lisa know.
have the fan relay system checked and if that works have someone look at the radiator you could have clogged tubes (happened to me after a bad head gasket on a neon).
srober32 is offline   Reply With Quote
Old 10-12-2005, 01:04 AM   #5
Mike White
CF Newbie
 
Join Date: Oct 2005
Location: NJ
Posts: 1
Engine - Running Hot And/Or Loss of Coolant

TB 00-06-02-001 JAN 00 Engine - Running Hot And/Or Loss of Coolant, it appears that GM has put many other TB about cooling problems.
I too have a over heating problem with my 1999 Olds Cutless V6 3.1 engine and I did all the things you have mentioned as first choice replacement but no head work. I have not seen this TB but it might be our answer. Let me know if you have found your grimlin. Mike
Mike White is offline   Reply With Quote
Old 10-12-2005, 11:56 AM   #6
dodger65
I know more than Wally...
 
dodger65's Avatar
 
Join Date: Apr 2005
Location: U.S. - Midwest
Posts: 2,117
... did anybody fix the tensioner? or is it still hanging there loose? i would start checking the cooling fan and relay. does the car have gauges? if so, let it idle and see what temp the fan kicks in (if it does) you should see it kick in before it gets into the red....
__________________
"Everyone is someone else's weirdo"

dodger65 is offline   Reply With Quote
Old 10-12-2005, 05:01 PM   #7
Adam13
CF Newbie
 
Join Date: Oct 2005
Posts: 34
Better make sure that the "good mechanic" put the belt on the right way for the water pump. If you did all those things, than it shouldnt overheat. Only thing left would be your fan. If it doesnt work or kick on, then wire it direct to your running lights or something. Also you should be able to watch your temp gauge and see when the thermostat opens. If it shoots past 200 without cooling down once, than its more than likely your thermostat. You're loosing coolant when it overheats. If it isnt leaking anywhere before that. I just went threw all of this crap but it turned out to be my head gaskets. I rebuilt the top end no more than 4 days ago, 112 miles then i rolled my car in front of my house. In the damn city. Talk about feeling stupid. Sure sounds like you love that little car. They're tough little bastards, hard to put to the grave. Another thought would be a cracked head, but you think they would have found that when you had them shaved.
Adam13 is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Forum Jump



All times are GMT +1. The time now is 07:19 AM.

Powered by vBulletin Version 3.5.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 2002 - 2011 Car Forums. All rights reserved.